HP Wolf Connect Service - Degraded Performance

Incident Report for HP Wolf Security

Resolved

Incident Summary:
Between July 4 and July 8, 2025, some HP Wolf Connect Service enabled devices experienced unexpected disconnections from our cloud platform.

Timeline (UTC):
- July 4, 03:30 – Our upstream IoT vendor performed scheduled maintenance and a system upgrade.
- July 4 onward – Devices began disconnecting unexpectedly and reporting offline status.
- July 7, 01:10 – Issue identified and investigation began.
- July 7, 07:30 – Root cause isolated as a failure in the upgrade process.
- July 7, 08:10 – Fix implemented and redeployed.
- July 8, 14:35 – All affected devices confirmed back online.

Root Cause:
The deployment process experienced an unhandled error during the upgrade, leading to a partial failure and unexpected device disconnections.

Resolution & Verification:
- The deployment process was corrected to properly handle this error.
- The updated deployment was successfully redeployed and verified, restoring connectivity to affected devices.

Preventive Actions:
- The vendor has improved their deployment process to better handle these errors and avoid partial failures.
- Future maintenance windows have been shifted to ensure faster incident response and support coverage.
- HP is implementing additional checks and monitoring to identify such failures sooner.

We sincerely apologize for any disruption this caused. We remain committed to delivering a reliable HP Wolf Connect Service and continue to work closely with our upstream vendor to improve deployment quality and operational resilience.
Posted Jul 10, 2025 - 16:18 BST

Monitoring

A fix has been implemented in the upstream HP Wolf Connect IoT service, and we are monitoring the results. Impacted devices are returning to an online state. No user action is required.

A post-incident root cause analysis (RCA) will be shared once additional details are available.
Posted Jul 08, 2025 - 12:24 BST

Identified

We are continuing to investigate this issue and have identified a problem with the HP Wolf Connect IoT service. The issue was detected at 01:10 UTC, and a fix was implemented at 08:10 UTC. Investigation is ongoing.

Some HP Wolf Connect devices may still appear offline or experience slow activations. Devices are expected to gradually return to online status over time. No user action is required, as devices will self-remediate.
Posted Jul 07, 2025 - 14:12 BST

Investigating

We are currently investigating an issue that may cause HP Wolf Connect devices to appear offline and may result in slow activations. Our team is working to identify the root cause and will provide updates as the investigation progresses.
Posted Jul 07, 2025 - 12:30 BST
This incident affected: HP Wolf Protect and Trace (Wolf Connect Service).