Sure Click 4.4 Release 10 (4.4.24.3261) Upgrade for [ENTERPRISE] software update channel

Scheduled for Jun 24, 10:00 - 13:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 14, 2025 - 16:38 BST

Scheduled

We would like to inform you about an upcoming scheduled Sure Click upgrade that will improve the quality and performance of our Sure Click service. We are committed to continuously enhancing our systems to provide you with the best possible experience.

During this time, any device that is assigned to the [ENTERPRISE] software update channel will have Sure Click 4.4.24.3261 automatically installed. A toast notification will inform the user that a reboot is required to complete the upgrade.

Release notes can be found here https://enterprisesecurity.hp.com/s/documentation

Our dedicated support team will be available to address any questions or concerns you may have. Should you require assistance, please do not hesitate to contact us at enterprise.support@hpwolf.com
Posted May 09, 2025 - 16:10 BST
This scheduled maintenance affects: HP Wolf Enterprise Security (Software Updates).